Windows 95/98

Home
Windows Support Menu

 

System Tools

Using Dr. Watson

Overview of Dr. Watson

Dr. Watson detects program errors and logs the diagnosis of the problem that caused the fault into a log file. The log file is created whenever a General Protection Fault (GPF) or page fault occurs. The log file can then be viewed to find what application caused the error, as well as the memory address where the fault occured.

The filename for the Dr. Watson application is "drwatson.exe", and is located in the \windows directory.

Starting and Using Dr. Watson

There are two ways to start Dr. Watson.

  1. The first is to simply open the "Run" dialog from the start menu, type "drwatson", and press enter.
  2. The longer method is to open MSInfo (Start, Run, MSInfo), and choose "Dr. Watson" from the "Tools" menu. When Dr. Watson is started, it always begins in a minimized mode.

In order to use Dr. Watson effectively, two things need to happen.

  • First, the GPF needs to be reproduced.
  • Second, Dr. Watson needs to be running in the background when the error occurs.

Sometimes the customer will be able to reproduce a GPF consistently. In these cases, just open Dr. Watson, and have the customer duplicate the GPF.

Most of the time though, the GPF's will be intermittant. In these cases, it may be best to make an alias of the Dr. Watson application (\windows\drwatson.exe), and put it in the StartUp group. Then have the customer reboot and use the computer normally until the next GPF occurs. When it does, he/she can call us back with the contents of the resulting Dr. Watson log file.

The log files that are created by Dr. Watson are named "Watsonxx.wlg", where "xx" is the number of the log file. By default, the log files are stored in the "windows\drwatson" folder. The default folder can be changed by adjusting the settings within Dr. Watson, however.

Log files are viewed from within MSInfo, or Dr. Watson itself. Open MSInfo, and select "Open" from the "File" menu, then choose the log file you wish to view. You can then compare the info in the log file to the standard MSInfo information. The log files can also be printed from within HWInfo. Keep in mind that a log file can be over 15 pages depending on the application that created the error.

Points to Remember

Launch Dr. Watson from the Run dialog or from the "Tools" menu in MSInfo.

Dr. Watson initailly starts in a minimized mode.

To troubleshoot erratic GPF's, put an alias of the Dr. Watson application (\windows\drwatson.exe) in the StartUp group.

Dr. Watson tends to work best with consistent, or easily reproducible GPF's.

When a GPF occurs, Dr. Watson automatically creates a log file named "watsonxx.wlg" (where xx is the number of the log file) in the "windows\drwatson" folder.

Log files can be viewd in Dr. Watson or MSInfo.

Dr. Watson does not report on system hangs, only GPF's.